Month: January 2015

CAT Adapter 3 (317-7484) replaced!

CAT Communication Adapter 3 (III) has been upgraded! CAT Adapter 3 The tried and true CAT Adapter 3 (Also know as the CAT Comm III)  adapter that is manufactured by Caterpillar has been upgraded. The old part number, 317-7484, has now been replaced by part number 466-6258. We took this opportunity to try and find out what has changed with this new adapter. The first thing we did is buy one, and open up the box. The box itself appears to be the exact same, and there are no changes that can be noticed. Here is what the inside looks like: There are 4 components in the box: CAT Comm Adapter III CD for installing the drivers USB Cable (From device to your computer) 6 & 9 pin cable (from device to your truck) We then took a closer look at the adapter itself. It is labeled with part # 317-7485 as you can see in this picture: This is the exact same part # as found in the original kit, part # 317-7484. So what gives? CAT raises the price a couple hundred dollars, but the adapter is the same? Lets dig a little further. The kit also contains a CD, USB cable, and 6/9 pin connector. Upon inspection, everything in this kit is exactly the same except for the provided connector pin cable. Here is what the old kit and the new kit contained from CAT:...

Read More

Premium Tech Tool (PTT) v2.x Tips & Tricks

Premium Tech Tool (PTT) v2.x Tips & Tricks For those of you that use Premium Tech Tool (Mack & Volvo Diagnostic Software), version 2.xx has been about for around 6 months at the time of this writing. A lot of customers report problems with this software or have questions, so here is our accumulated knowledge of this program. The Auto-Detect Feature won’t work! According to Premium Tech Tool, if you are updated to v2.03.xx or higher, is should auto detect. However, I find this to be false. In our experience, it does auto-detect with everything except for older Mack trucks. These would be trucks running V-MACIII ECM, which is early 2000’s and older. In this case, you will need to manually select the ECM. Premium Tech Tool v2.xx gives me a security and/or Java error! From talking with the good folks at tech support at Premium Tech Tool, this is because there are only 2 versions of Java that work. This would be Java v6 update 31 or Java v7 update 51. You need to make sure you have *only* one of those versions installed. You then need to turn the security settings down to “low” on the Java control panel and disable all updates. PTT v1.12.xx or PTT v2.xx? In January of 2015, Volvo has announced that Premium Tech Tool will stop working come June 1st, 2015. I...

Read More

Join our mailing list

Powered by Robly